11 Августа 2020, 13:09

smartcam

Автор НаРазДва, 05 Марта 2012, 23:15

« предыдущая тема - следующая тема »

0 Пользователей и 1 Гость просматривают эту тему.

НаРазДва

Привет всем. Кто пользовался этим творением? Что только не перепробовал, картинки с телефона нет.
1. Протатчил, скомпилил дрова. Модуль грузится, в /dev/ появляется устройство videoX.
2. Запускаю сам смарткам, вроде всё "зашибсь" - ошибок, что нет девайса из п.1 - нету.
3. Запускаю смарткам на мобильнике, тоже все "зашибись".
4. Коннекчусь к серверу, т.е. к програмке из п.2, - статус "connected" и картинка с камеры на телефоне отображается.
5. В проге из п.2 - ничего не меняется - статус "disconnected" и картинки с трубки нет.
6. Опытным путём выяснил, что телефон всё-таки коннектится к этой программулине, а ей "хоть бы хны".

Есть подозрение на несовместимость с модулями блютуза.

У кого есть опыт настройки данного симбиан-линукс симбиоза? Как локализовать проблему?

Yoda

Как-то  так можно попробовать узнать, имеется ли конфликт с чем-либо.

НаРазДва

Цитата: Yoda от 06 Марта 2012, 11:52Как-то  так можно попробовать узнать, имеется ли конфликт с чем-либо.

Мастер Йода, похоже видео-потока нет, выделено бардовым. Где-то всё таки затык.

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

root-debian{~}: mplayer tv:// -tv driver=v4l2:device=/dev/video1:width=640:height=480
MPlayer 1.0rc3-4.4.4 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
TV file format detected.
Selected driver: v4l2
 name: Video 4 Linux 2 input
 author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
 comment: first try, more to come ;-)
Selected device: smartcam
 Capabilites:  video capture  read/write  streaming
 supported norms: 0 = NTSC-M;
 inputs: 0 = smartcam input;
 Current input: 0
 Current format: YUYV
[color="#8b0000"]v4l2: ioctl set format failed: Invalid argument[/color]
[color="#8b0000"]v4l2: ioctl set mute failed: Invalid argument[/color]
[color="#8b0000"]v4l2: 0 frames successfully processed, 0 frames dropped.[/color]


Exiting... (End of file)
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Yoda

Вот что-то похожее - ссылка. Ошибки (которые выделены в Вашем сообщении) вроде обычное явление, как я понял.

НаРазДва

Цитата: Yoda от 06 Марта 2012, 21:14Вот что-то похожее - ссылка. Ошибки (которые выделены в Вашем сообщении) вроде обычное явление, как я понял.

Перегрузил модуль uvcvideo с параметрами, которые указаны по ссылке.
Результат: смарткам с телефона по блютузу коннектится (статус устройства в настройках блютуза - отображается как соединено),
но следом выдаёт ошибку "disconnected-18".  Всезнающий гугль по-этому поводу молчит. Хотя это уже что-то.