Автор Тема: Настройка xorg для ATI Radeon.  (Прочитано 2805 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Avvodonich

  • Новичок
  • *
  • Сообщений: 5
  • Karma: +0/-0
Настройка xorg для ATI Radeon.
« : 27 Октябрь 2010, 20:59 »
Не могу поднять xorg =(
Видеокарта Radeon x1300-x1550, чип rv515.
Архитектура amd64.

Проблему так и не решил, хотя прошло уже больше месяца, наверно потому что я это дело бросил, что бы нервы себе не портить, и вспомнив что не доделал решил опять взяться, поковырявшись немного опять не фига не получилось, поэтому напишу подробно что я делал.

в ядро включено

Device Drivers --->
 Input device support --->
 <*> Event interface
____________________________________

Device Drivers --->
 Graphics support --->
Support for frame buffer devices --->
(Disable all drivers, including VGA, Intel, nVidia, and ATI)

(Further down, enable basic console support. KMS uses this.)
Console display driver support --->
  <*> Framebuffer Console Support
____________________________________

(Enable Radeon KMS support)
Device Drivers --->
 Graphics support --->
 <*> Direct Rendering Manager --->
 <*> ATI Radeon
 [*] Enable modesetting on radeon by default

Потом залез в make.conf
INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="radeon"
Далее
emerge xorg-x11
emerge xorg-drivers (драйвер xf86-video-ati)
env-update && source /etc/profile
Xorg -configure
Xorg -config /root/xorg.conf.new

После запуска проверки xorg.conf.new выдает темный экран и нечего не происходит нажимаю Ctrl+Alt +Backspace не реагирует, Ctrl+Alt +F1 выходит опять в консоль где примерно такой текст:
Config file '/root/xorg.conf.new'
[KMS] Kernel mode setting enable
_ <--(тут мигает маркер, и не чего не происходит )

Вот всякая инфа:

lspci -k
04:00.0 VGA compatible controller: ATI Technologies Inc RV515 [Radeon X1300]
  Subsystem: Hightech Information System Ltd. Device 2058
  Kernel driver in use: radeon
04:00.1 Display controller: ATI Technologies Inc RV515 [Radeon X1300] (Secondary)
  Subsystem: Hightech Information System Ltd. Device 2059


Xorg.0.log
[spoiler]

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.34-gentoo-r12 x86_64
Current Operating System: Linux localhost 2.6.34-gentoo-r12 #5 SMP Sat Nov 6 00:01:55 ALMT 2010 x86_64
Kernel command line: root=/dev/sda3
Build Date: 16 November 2010 08:51:36PM
 
Current version of pixman: 0.18.2
  Before reporting problems, check [url="http://wiki.x.org"]http://wiki.x.org[/url]
  to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 17 01:24:02 2010
(++) Using config file: "/root/xorg.conf.new"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Not automatically adding devices
(==) Not automatically enabling devices
(**) FontPath set to:
  /usr/share/fonts/misc/,
  /usr/share/fonts/TTF/,
  /usr/share/fonts/OTF,
  /usr/share/fonts/Type1/,
  /usr/share/fonts/100dpi/,
  /usr/share/fonts/75dpi/,
  /usr/share/fonts/misc/,
  /usr/share/fonts/TTF/,
  /usr/share/fonts/OTF,
  /usr/share/fonts/Type1/,
  /usr/share/fonts/100dpi/,
  /usr/share/fonts/75dpi/
(**) ModulePath set to "/usr/lib64/xorg/modules"
(II) Loader magic: 0x7bd020
(II) Module ABI versions:
  X.Org ANSI C Emulation: 0.4
  X.Org Video Driver: 6.0
  X.Org XInput driver : 7.0
  X.Org Server Extension : 2.0
(--) using VT number 7


 
(--) PCI:*(0:4:0:0) 1002:7146:17af:2058 ATI Technologies Inc RV515 [Radeon X1300] rev 0, Mem @ 0xe0000000/268435456, 0xdffe0000/65536,
I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
(--) PCI: (0:4:0:1) 1002:7166:17af:2059 ATI Technologies Inc RV515 [Radeon X1300] (Secondary) rev 0, Mem @ 0xdfff0000/65536
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 1.0.0
  Module class: X.Org Server Extension
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "record"
(II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 1.13.0
  Module class: X.Org Server Extension
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 1.0.0
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 1.0.0
  ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 1.0.0
  Module class: X.Org Server Extension
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "dri2"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 1.1.0
  ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "radeon"
(II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 6.13.1
  Module class: X.Org Video Driver
  ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "mouse"
(II) Loading /usr/lib64/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 1.5.0
  Module class: X.Org XInput Driver
  ABI class: X.Org XInput driver, version 7.0
(II) LoadModule: "kbd"
(II) Loading /usr/lib64/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 1.4.0
  Module class: X.Org XInput Driver
  ABI class: X.Org XInput driver, version 7.0
(II) RADEON: Driver for ATI Radeon chipsets:
  ATI Radeon Mobility X600 (M24) 3150 (PCIE), ATI FireMV 2400 (PCI),
  ATI Radeon Mobility X300 (M24) 3152 (PCIE),
 ...................................................................
  ATI FirePro (FireGL) Graphics Adapter,
  ATI FirePro (FireGL) Graphics Adapter, CEDAR, ATI Radeon HD 5450,
  CEDAR
(II) Primary Device is: PCI 04@00:00:0
(II) [KMS] Kernel modesetting enabled.
(==) RADEON(0): Depth 24, (--) framebuffer bpp 32
(II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(==) RADEON(0): Default visual is TrueColor
(==) RADEON(0): RGB weight 888
(II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
(--) RADEON(0): Chipset: "ATI Radeon X1300/X1550" (ChipID = 0x7146)
(II) RADEON(0): PCIE card detected
(II) RADEON(0): KMS Color Tiling: enabled
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: Searching for BusID pci:0000:04:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports pci:0000:04:00.0
(II) RADEON(0): Output VGA-0 using monitor section Monitor0
(II) RADEON(0): Output S-video has no monitor section
(II) RADEON(0): Output DVI-0 has no monitor section
(II) RADEON(0): EDID vendor "GSM", prod id 17458
(II) RADEON(0): Using hsync ranges from config file
(II) RADEON(0): Using vrefresh ranges from config file
(II) RADEON(0): Printing DDC gathered Modelines:
(II) RADEON(0): Modeline "1280x1024"x0.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
(II) RADEON(0): Modeline "800x600"x0.0 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz)
(II) RADEON(0): Modeline "640x480"x0.0 31.50 640 656 720 840 480 481 484 500 -hsync -vsync (37.5 kHz)
(II) RADEON(0): Modeline "640x480"x0.0 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz)
(II) RADEON(0): Modeline "720x400"x0.0 28.32 720 738 846 900 400 412 414 449 -hsync +vsync (31.5 kHz)
(II) RADEON(0): Modeline "1280x1024"x0.0 135.00 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
(II) RADEON(0): Modeline "1024x768"x0.0 78.75 1024 1040 1136 1312 768 769 772 800 +hsync +vsync (60.0 kHz)
(II) RADEON(0): Modeline "1024x768"x0.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz)
(II) RADEON(0): Modeline "832x624"x0.0 57.28 832 864 928 1152 624 625 628 667 -hsync -vsync (49.7 kHz)
(II) RADEON(0): Modeline "800x600"x0.0 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync (46.9 kHz)
(II) RADEON(0): Modeline "1152x864"x0.0 108.00 1152 1216 1344 1600 864 865 868 900 +hsync +vsync (67.5 kHz)
(II) RADEON(0): Output VGA-0 connected
(II) RADEON(0): Output S-video disconnected
(II) RADEON(0): Output DVI-0 disconnected
(II) RADEON(0): Using exact sizes for initial modes
(II) RADEON(0): Output VGA-0 using initial mode 1280x1024
(II) RADEON(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
(II) RADEON(0): mem size init: gart size :1fdff000 vram size: s:10000000 visible:fac0000
(II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM
(**) RADEON(0): Display dimensions: (340, 270) mm
(**) RADEON(0): DPI set to (95, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib64/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 1.0.0
  ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) Loading sub module "exa"
(II) LoadModule: "exa"
(II) Loading /usr/lib64/xorg/modules/libexa.so
(II) Module exa: vendor="X.Org Foundation"
  compiled for 1.7.7, module version = 2.5.0
  ABI class: X.Org Video Driver, version 6.0
(--) Depth 24 pixmap format is 32 bpp
(II) RADEON(0): [DRI2] Setup complete
(II) RADEON(0): Front buffer size: 5120K
(II) RADEON(0): VRAM usage limit set to 226483K
(==) RADEON(0): Backing store disabled
(II) RADEON(0): Direct rendering enabled
(II) RADEON(0): Render acceleration enabled for R300/R400/R500 type cards.
(II) RADEON(0): Setting EXA maxPitchBytes
(II) EXA(0): Driver allocated offscreen pixmaps
(II) EXA(0): Driver registered support for the following operations:
(II) Solid
(II) Copy
(II) Composite (RENDER acceleration)
(II) UploadToScreen
(II) DownloadFromScreen
(II) RADEON(0): Acceleration enabled
(**) RADEON(0): DPMS enabled
(==) RADEON(0): Silken mouse enabled
(II) RADEON(0): Set up textured video
(II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(--) RandR disabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_make_current_read
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
(II) AIGLX: Loaded and initialized /usr/lib64/dri/r300_dri.so
(II) GLX: Initialized DRI2 GL provider for screen 0
(II) RADEON(0): Setting screen physical size to 338 x 270
(**) Option "Protocol" "auto"
(**) Option "Device" "/dev/input/mice"
(II) Mouse0: Setting mouse protocol to "ExplorerPS/2"
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: always reports core events
(**) Option "Device" "/dev/input/mice"
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5 6 7"
(**) Mouse0: ZAxisMapping: buttons 4, 5, 6 and 7
(**) Mouse0: Buttons: 11
(**) Mouse0: Sensitivity: 1
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(**) Mouse0: (accel) keeping acceleration scheme 1
(**) Mouse0: (accel) acceleration profile 0
(II) Mouse0: Setting mouse protocol to "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
(**) Option "CoreKeyboard"
(**) Keyboard0: always reports core events
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "XkbRules" "base"
(**) Keyboard0: XkbRules: "base"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Keyboard0: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) AIGLX: Suspending AIGLX clients for VT switch
(II) UnloadModule: "kbd"
(II) UnloadModule: "mouse"
[/spoiler]

xorg.conf.new
[spoiler]
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/OTF"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
Load "extmod"
Load "record"
Load "dri"
Load "glx"
Load "dbe"
Load "dri2"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
#DisplaySize 340 270 # mm
Identifier "Monitor0"
VendorName "GSM"
ModelName ""
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
  ### Available Driver options are:-
  ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
  ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
  ### [arg]: arg optional
  #Option "NoAccel" # [<bool>]
  #Option "SWcursor" # [<bool>]
  #Option "Dac6Bit" # [<bool>]
  #Option "Dac8Bit" # [<bool>]
  #Option "BusType" # [<str>]
  #Option "CPPIOMode" # [<bool>]
  #Option "CPusecTimeout" # <i>
  #Option "AGPMode" # <i>
  #Option "AGPFastWrite" # [<bool>]
  #Option "AGPSize" # <i>
  #Option "GARTSize" # <i>
  #Option "RingSize" # <i>
  #Option "BufferSize" # <i>
  #Option "EnableDepthMoves" # [<bool>]
  #Option "EnablePageFlip" # [<bool>]
  #Option "NoBackBuffer" # [<bool>]
  #Option "DMAForXv" # [<bool>]
  #Option "FBTexPercent" # <i>
  #Option "DepthBits" # <i>
  #Option "PCIAPERSize" # <i>
  #Option "AccelDFS" # [<bool>]
  #Option "IgnoreEDID" # [<bool>]
  #Option "CustomEDID" # [<str>]
  #Option "DisplayPriority" # [<str>]
  #Option "PanelSize" # [<str>]
  #Option "ForceMinDotClock" # <freq>
  #Option "ColorTiling" # [<bool>]
  #Option "VideoKey" # <i>
  #Option "RageTheatreCrystal" # <i>
  #Option "RageTheatreTunerPort" # <i>
  #Option "RageTheatreCompositePort" # <i>
  #Option "RageTheatreSVideoPort" # <i>
  #Option "TunerType" # <i>
  #Option "RageTheatreMicrocPath" # <str>
  #Option "RageTheatreMicrocType" # <str>
  #Option "ScalerWidth" # <i>
  #Option "RenderAccel" # [<bool>]
  #Option "SubPixelOrder" # [<str>]
  #Option "ClockGating" # [<bool>]
  #Option "VGAAccess" # [<bool>]
  #Option "ReverseDDC" # [<bool>]
  #Option "LVDSProbePLL" # [<bool>]
  #Option "AccelMethod" # <str>
  #Option "DRI" # [<bool>]
  #Option "ConnectorTable" # <str>
  #Option "DefaultConnectorTable" # [<bool>]
  #Option "DefaultTMDSPLL" # [<bool>]
  #Option "TVDACLoadDetect" # [<bool>]
  #Option "ForceTVOut" # [<bool>]
  #Option "TVStandard" # <str>
  #Option "IgnoreLidStatus" # [<bool>]
  #Option "DefaultTVDACAdj" # [<bool>]
  #Option "Int10" # [<bool>]
  #Option "EXAVSync" # [<bool>]
  #Option "ATOMTVOut" # [<bool>]
  #Option "R4xxATOM" # [<bool>]
  #Option "ForceLowPowerMode" # [<bool>]
  #Option "DynamicPM" # [<bool>]
  #Option "NewPLL" # [<bool>]
  #Option "ZaphodHeads" # <str>
Identifier "Card0"
Driver "radeon"
VendorName "ATI Technologies Inc"
BoardName "RV515 [Radeon X1300]"
BusID "PCI:4:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
[/spoiler]

Если надо могу дать вывод dmesg
« Последнее редактирование: 16 Ноябрь 2010, 20:48 от Avvodonich »

Оффлайн hedgeven

  • Administrator
  • Свой человек
  • *****
  • Сообщений: 853
  • Karma: +13/-0
  • Jabber: hedgeven@xmpp.kz
Настройка xorg для ATI Radeon.
« Ответ #1 : 27 Октябрь 2010, 22:13 »
Я не знаю что вы делали, поэтому сначала по пунктам:
1. в /etc/make.conf вносим/изменяем строку VIDEO_CARDS="fglrx"
2. пересобираем x11-base/xorg-drivers
3. настраиваем иксы под новый драйвер: aticonfig --initial --input=/etc/X11/xorg.conf
4. переходим на использование проприетарного драйвера: sudo eselect opengl set ati
« Последнее редактирование: 28 Октябрь 2010, 22:58 от Zhek@Ch »
Jah will give us everything...

Оффлайн Avvodonich

  • Новичок
  • *
  • Сообщений: 5
  • Karma: +0/-0
Настройка xorg для ATI Radeon.
« Ответ #2 : 28 Октябрь 2010, 21:43 »
я не знаю что вы делали, поэтому сначала по пунктам:
1. в /etc/make.conf вносим/изменяем строку VIDEO_CARDS="fglrx"
2. пересобираем x11-base/xorg-drivers
3. настраиваем иксы под новый драйвер: aticonfig --initial --input=/etc/X11/xorg.conf
4. переходим на использование проприетарного драйвера: sudo eselect opengl set ati

На aticonfig --initial --input=/etc/X11/xorg.conf говорит что не может найти устройство, я в принципе знал что так будет но решил все таки проверить.
Я подозреваю что проблема в том, что ati уже не выпускает драйвера на мою видюшку, последние обновления 3/26/2009 года, а последние свежие драйвера идут с чипов v600, где то читал на форуме что тот старый драйвер не поддерживает ядра выше 2.6.29, правда или нет я не знаю потому что тот чел ссылок на источник не дал, да и где читал не помню.
« Последнее редактирование: 28 Октябрь 2010, 22:59 от Zhek@Ch »

Оффлайн Avvodonich

  • Новичок
  • *
  • Сообщений: 5
  • Karma: +0/-0
Настройка xorg для ATI Radeon.
« Ответ #3 : 17 Ноябрь 2010, 20:59 »
Я так понимаю мне здесь не кто не поможет =(

Оффлайн Vicpo

  • Супер модераторы
  • Свой человек
  • ***
  • Сообщений: 2170
  • Karma: +5/-0
  • Jabber: vicpo@xmpp.kz
Настройка xorg для ATI Radeon.
« Ответ #4 : 18 Ноябрь 2010, 09:36 »
Да старые дрова не поддерживают ядра 2.6.3x Используйте свободные драйвера или делайте апгрейд компа

Оффлайн hedgeven

  • Administrator
  • Свой человек
  • *****
  • Сообщений: 853
  • Karma: +13/-0
  • Jabber: hedgeven@xmpp.kz
Настройка xorg для ATI Radeon.
« Ответ #5 : 18 Ноябрь 2010, 14:25 »
Надо сказать, что свободные дрова уже хороши. Нетребовательные к графике игры идут.
А если прикрутить kms+mesa+gallium то запускается даже Lineage 2, хоть и с глюками, но учитывая что разработки активно идут...

В общем попробовал я недавно закрытый драйвер, два дня бился с непросыпанием видяшки и вернулся на свободные.
« Последнее редактирование: 18 Ноябрь 2010, 21:59 от Zhek@Ch »
Jah will give us everything...

Оффлайн Avvodonich

  • Новичок
  • *
  • Сообщений: 5
  • Karma: +0/-0
Настройка xorg для ATI Radeon.
« Ответ #6 : 18 Ноябрь 2010, 18:44 »
Всем спасибо =)) проблема была, а вернее её не было, все работало, просто на X -config /root/xor.conf.new начиная с версий иксов 7.4 показывает темный экран, для того что бы увидеть курсор и серый экран, как это было раньше, нужно набрать X -config /root/xor.conf.new -retro
Думаю это важно и нужно запихать в какой нибудь FAQ, что бы люди как я не портили себе нервы =)))

З.Ы.: Тему можно закрывать.
« Последнее редактирование: 18 Ноябрь 2010, 22:00 от Zhek@Ch »

 

Соц. сети

Вконтакте - linuxforum.kz Вконтакте - LinuxCenter.kZ

СПО в Казахстане

LinuxCenter.kZ Jabber сервер XMPP.kz Baurzhan.info

Прочее

nmgames.kz radio.north.kz