Автор Тема: Проблема старта startx и/или установки драйверов ATI.  (Прочитано 1902 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн TIT

  • Новичок
  • *
  • Сообщений: 4
  • Karma: +0/-0
На ноутбук (Samsung R60) поставил Archlinux (x64).
Установил (по wiki) hal, xorg, gnome-desktop, gnome-extra
Установил драйвер ati-driver-installer-10-3-x86.x86_64.run
Не запускается startx.
Видеокарта ATI HD 2xxx.
Лог /var/log/xorg.log --> http://paste.ubuntu.com/412347/
Подскажите, в какую сторону капать?[twitter]titnet[/twitter]

Оффлайн Vicpo

  • Супер модераторы
  • Свой человек
  • ***
  • Сообщений: 2170
  • Karma: +5/-0
  • Jabber: vicpo@xmpp.kz
http://megabytov.net - выложите сам /etc/X11/xorg.conf

Оффлайн hedgeven

  • Administrator
  • Свой человек
  • *****
  • Сообщений: 853
  • Karma: +13/-0
  • Jabber: hedgeven@xmpp.kz
судя по логу у вас неправильно составлен xorg.conf.
вот настройка Xorg и собственно Ati.
и да, [color="#1C2837"][font="arial, verdana, tahoma, sans-serif"][size="2"]ati-driver-10.3 еще не умеет работать с [color="#000000"][size="3"]xorg-server-1.7. поддержка будет только в ati-drivers-10.4[/size][/color][/size][/font][/color]
[color="#1C2837"][font="arial, verdana, tahoma, sans-serif"][size="2"][color="#000000"][size="3"]что можно сделать:[/size][/color][/size][/font][/color]
[color="#1C2837"][font="arial, verdana, tahoma, sans-serif"][size="2"][color="#000000"][size="3"]1. можно ждать версию ati-drivers-10.4 на открытых драйверах[/size][/color][/size][/font][/color]
[color="#1C2837"][font="arial, verdana, tahoma, sans-serif"][size="2"][color="#000000"][size="3"]2. можно установить xorg-server <1.7[/size][/color][/size][/font][/color]
[color="#1C2837"][font="arial, verdana, tahoma, sans-serif"][size="2"][color="#000000"][size="3"]3. можно поискать пререлиз ati-driver с поддержкой xorg-server-1.7[/size][/color][/size][/font][/color]
« Последнее редактирование: 11 Апрель 2010, 08:51 от hedgeven »
Jah will give us everything...

Оффлайн TIT

  • Новичок
  • *
  • Сообщений: 4
  • Karma: +0/-0
Поставил xf86-video-ati.
При запуске X, Xorg, startx, gnome-session ноут уходил в чёрный экран и наглухо зависал.
Помог только запуск gdm, который и запустил потом Gnome.
Сейчас ноут загружается в консоль. Потом ручками /etc/rc.d/hal start и gdm
Пока так. Дальше -- читать документацию, как это всё автоматизирвоать. )

Оффлайн Vicpo

  • Супер модераторы
  • Свой человек
  • ***
  • Сообщений: 2170
  • Karma: +5/-0
  • Jabber: vicpo@xmpp.kz
Поставил xf86-video-ati.
При запуске X, Xorg, startx, gnome-session ноут уходил в чёрный экран и наглухо зависал.
Помог только запуск gdm, который и запустил потом Gnome.
Сейчас ноут загружается в консоль. Потом ручками /etc/rc.d/hal start и gdm
Пока так. Дальше -- читать документацию, как это всё автоматизирвоать. )
/etc/rc.conf
DAEMONS=(........ hal)

/etc/inittab
id:5:initdefault:

....
x:5:respawn:/usr/sbin/gdm -nodaemon

Оффлайн TIT

  • Новичок
  • *
  • Сообщений: 4
  • Karma: +0/-0
/etc/rc.conf
DAEMONS=(........ hal)

/etc/inittab
id:5:initdefault:

....
x:5:respawn:/usr/sbin/gdm -nodaemon
В демоны добавил, вместе с нетворкманагером, фамом и гдм.
Иниттаб не трогал. Как-то так заработало.


Сейчас ноутбук грузится полностью самостоятельно до окна GDM, после авторизации запускается gnome.
Но остались остатки моих игр с АТИ. А именно в меню Система есть 2 пункта с АТИ. Конфигуратор и Администратор. Оба не запускаются и ругаются, что надо aticonfig использовать...
Как это удалить можно? Т. е. посмотреть, какие именно сейчас стоят драйвера на видео и удалить их все что ли и поставить только опенсёрсные, как тут советовали? Мне не для игр, просто графика нужна, что бы гном грузился.


Ещё одна интересная особенность, у меня в системе нет вообще файла xorg.conf, который везде советуют редактировать...

 

Соц. сети

Вконтакте - linuxforum.kz Вконтакте - LinuxCenter.kZ

СПО в Казахстане

LinuxCenter.kZ Jabber сервер XMPP.kz Baurzhan.info

Прочее

nmgames.kz radio.north.kz